четверг, 26 января 2012 г.

1C8 чтение XML файла

Чтение = Новый ЧтениеXML; Чтение.ОткрытьФайл(ПутьКФайлу); Пока Чтение.Прочитать() Цикл     // Прочитать "структурные части" элементов.       // Проверить, какая часть элемента - текущая.       Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда         ИмяУзла = Чтение.Имя; Сообщить("--" + ИмяУзла);         // Атрибуты элементов можно читать только если текущая часть -           // начало элемента           Пока Чтение.ПрочитатьАтрибут() Цикл             // Прочитать данные узла атрибута.               ТипУзла = Чтение.ТипУзла;             Имя = Чтение.Имя;             Значение = Чтение.Значение;             // Обработать полученные значения.         КонецЦикла;     ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.Текст Тогда         // В примере просто выводим текст в окно сообщений.           Сообщить("Текст:" + Чтение.Значение);     ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда         // В примере просто выводим признак конца элемента           // в окно сообщений Сообщить("--Конец:" + Чтение.Имя);       КонецЕсли; КонецЦикла;

Комментариев нет:

Отправка комментария