среда, 3 июля 2019 г.

1С Excel

Само сохранение:
ТабДок.Записать(ПутьКФайлу, ТипФайлаТабличногоДокумента.XLSX);

Подготовка данных, 2 метода, второй более "красивый".
&НаСервере
Функция ТЗ_В_ТабДок(ТаблицаЗначений) Экспорт
ТабДок = Новый ТабличныйДокумент;
Построитель = Новый ПостроительОтчета;
Построитель.ИсточникДанных=Новый ОписаниеИсточникаДанных(ТаблицаЗначений);       
Построитель.Вывести(ТабДок);
Возврат ТабДок;
КонецФункции

&НаСервере
Функция Запрос_В_ТабДок(Запрос) Экспорт
ТабДок = Новый ТабличныйДокумент;
Результат = Запрос.Выполнить();
Колонки = Результат.Колонки;
Выборка = Результат.Выбрать();
Количество = Выборка.Количество()+2;
// рисуем заголовки
кол = 1;
стр = 1;
Для Каждого колонка Из Колонки цикл
Имяобласть = "R1C" + Строка(кол);
ТабДок.Область(Имяобласть).Текст = колонка.Имя;
кол = кол + 1;
КонецЦикла;
Пока Выборка.Следующий() Цикл
кол = 1;
стр = стр + 1;
Для Каждого колонка Из Колонки цикл
Имяобласть = "R" + Строка(стр) + "C" + Строка(кол);
ТабДок.Область(Имяобласть).Текст = Выборка[колонка.Имя];
кол = кол + 1;
КонецЦикла;
КонецЦикла;
Возврат ТабДок;
КонецФункции

Первый метод взят отсюда:
Источник: https://pro1c8.ru/obmen-excel-1c/#tablichnyjdokument

Комментариев нет:

Отправить комментарий